Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jun 18, 2025 - 10:30 EDT
Scheduled
At Layer27, we take security seriously and continuously align our practices with leading cybersecurity frameworks, including NIST SP 800-53, CIS Controls, and Zero Trust principles. A recently disclosed vulnerability in Veeam Backup & Replication (KB4743) affects systems that are domain joined. To maintain the security and integrity of our infrastructure, we will be rolling out the official Veeam patch across our internal systems. This patching activity is part of our ongoing commitment to protect our clients and comply with industry best practices. To minimize disruption, any impacted client environments under our management will be placed into maintenance mode between 10:30 AM and 5:00 PM ET during the patch window. We will coordinate directly with clients if additional steps or considerations are required. For customers who self-manage a domain-joined Veeam deployment, we strongly recommend applying the patch immediately. If you have any questions or concerns, please don’t hesitate to reach out to your Layer27 account team.
Posted Jun 18, 2025 - 10:20 EDT
This scheduled maintenance affected: EAST-3 (Backup Services), CENTRAL-1 (Backup Services, Disaster Recovery Services), and EAST-2 (Backup Services, Disaster Recovery Services).